BVEStation

Author Topic: [RESOLVED] R46 4 car set problem  (Read 558 times)

Offline BadriveR142A

  • Conductor
  • **
  • Posts: 124
  • Rating: +8/-2
  • Gender: Male
  • 1970s Route Developper & Graphic Designer
    • View Profile
[RESOLVED] R46 4 car set problem
« on: June 15, 2017, 12:52:45 pm »
Ok, I downloaded the G line a while ago and wanted to test it with the 4 car set of R46. When the game started, the first thing I've noticed was that the cab was completely out of the tracks and then I heard that the sounds were high pitched, I inspected the sound folder of the 4 car set and the sounds were ok.
This is the only problem that I've got at the moment so it's not a missing dependencie issue.

I was using the 1.4.3.0 version and now I installed the 1.5.1.2 version, and I did not try yet because I'm moving all Routes and Trains from the older version and it takes a while, plus I haven't downloaded all dependencies yet.
My idea is: I should change the extension.cfg file from the 8 car set myself and see if it works fine.
But first I will try on 1.5.1.2 version of BVE whithout changing anything once I get everything installed.

I just want to know where the problem comes from, this is why I posted this.
« Last Edit: June 17, 2017, 11:25:30 am by BadriveR142A »

1960 - 1980s Lover

Offline BadriveR142A

  • Conductor
  • **
  • Posts: 124
  • Rating: +8/-2
  • Gender: Male
  • 1970s Route Developper & Graphic Designer
    • View Profile
Re: R46 4 car set problem
« Reply #1 on: June 15, 2017, 02:02:53 pm »
Same thing on the 1.5.1.2 version, have to change the 8 car set's extension.cfg file myself then, but if you have any ideas on where does this problem come from let me know please I'm very curious

1960 - 1980s Lover

Offline YankeesPwnMets

  • Head Admin
  • Dispatcher
  • ******
  • Posts: 679
  • Rating: +13/-9
  • Gender: Male
  • Lexington Av Express
    • View Profile
Re: R46 4 car set problem
« Reply #2 on: June 15, 2017, 04:06:54 pm »
Check your PMs

Offline BadriveR142A

  • Conductor
  • **
  • Posts: 124
  • Rating: +8/-2
  • Gender: Male
  • 1970s Route Developper & Graphic Designer
    • View Profile
Re: R46 4 car set problem
« Reply #3 on: June 17, 2017, 11:24:56 am »
OK I resolved it, the issue was the train.dat file, not the extension.cfg file.
So I just put the train.dat file from the 8 car set to the 4 car set folder, then I still had 4 grey boxes behind the 4th car, so I changed the Numbers of motor cars from 24 to 12 in the train.dat file and Voilą.
So the reason why the cab was completely out of the tracks and the sounds were high pitched was because of the position values (X,Y,Z) and the acceleration values, resulting in sound modification.

So if you have the same problem, do this.


1960 - 1980s Lover