BVEStation

Author Topic: OpenBve Under Linux/Mono  (Read 1462 times)

Offline Low_V

  • New Recruit
  • *
  • Posts: 6
  • Gender: Male
  • BVEStation Member
    • View Profile
OpenBve Under Linux/Mono
« on: February 11, 2015, 04:27:27 pm »
Hi, I have successfully been running OpenBve under Fedora 19 and 20 (Linux) running under mono. Everything works flawlessly. When I upgraded to the latest Fedora 21 OpenBve would not run at all. I couldn't even get the program to startup. Apparently the newer versions of mono that are packaged with Fedora 21 no longer support OpenBve. Fortunately I managed to fix the prioblem.  In order to get it up and running I had to downgrade the mono packages to the older ones from fedora 20. As soon as I downgraded to the earliier versions of mono OpenBve started working again.

Wonder if anyone else noticed this problem. In any event I figured I'd post this as a heads up to anyone who might be running OpenBve on Linux via mono. If you are using a current version of mono and OpenBve won;t run you might have to downgrade/install an earlier version of mono in order to get it to work.

Offline Dj Hammers

  • Head Admin
  • Supervisor
  • ******
  • Posts: 1,034
  • Gender: Male
  • 7 Years of Developing for openBVE!
    • View Profile
    • My YouTube Channel
Re: OpenBve Under Linux/Mono
« Reply #1 on: February 11, 2015, 06:42:27 pm »
What version number of mono did you downgrade to?

Offline Low_V

  • New Recruit
  • *
  • Posts: 6
  • Gender: Male
  • BVEStation Member
    • View Profile
Re: OpenBve Under Linux/Mono
« Reply #2 on: February 11, 2015, 10:17:44 pm »
mono version 2.10.8-5. This is the version that came packaged with Fedora 20. Basically I just erased the newer mono packages from fedora 21 and installed the older Fedora 20 mono packages . So far it's the only way I have been able to get OpenBve to work on Fedora 21.