BVEStation

Author Topic: Disable ATS on Trains? (Roll Sign Problem)  (Read 3326 times)

Offline Greywolf

  • New Recruit
  • *
  • Posts: 13
  • Gender: Male
  • BVEStation Member
    • View Profile
Disable ATS on Trains? (Roll Sign Problem)
« on: April 30, 2014, 12:56:38 pm »
Is this possible? It is interfering with the Roll Sign Functions on some trains that have it.

The new R38, I have no issues with, and ATS appears to be completely disabled for it. However I can't change the roll signs on the new R32. I read that the ATS plugin as well as your Antivirus program can cause the Roll Sign function to not work. However I have the entire folder where OpenBVE is installed added as an exception, and I have no issues with the R38, so that can't be the problem.

I tried removing all of the ATS txt and dll files from the train folder but ATS was still functional.  :-\

Thanks in advance for any assistance.
« Last Edit: April 30, 2014, 01:11:25 pm by Greywolf »

Offline Greywolf

  • New Recruit
  • *
  • Posts: 13
  • Gender: Male
  • BVEStation Member
    • View Profile
Re: Disable ATS on Trains?
« Reply #1 on: April 30, 2014, 01:00:36 pm »
Right after I posted this question, I managed to solve the issue myself through trial and error. I simply copied the OS_Ats1.dll from the new R38 (10 car folder) and stuck it in the R32 folder for the train I wanted to use and presto, the Roll Signs work fine now.

Update: I copied this dll to the rest of the R32 trains and picked two at random and the Roll Sign function is working perfect now. The dll that came with the R32 must have been corrupt or something. I am leaving these posts up to help anyone else having this problem.

Update 2: Ok so everything was fine for a day, then the problem started happening again. I updated to the newest OpenBVE and I tried copying the OS_Ats1.dll from the updated R46 and tried several trains I was having problems with and the issue seemed to have cleared up again. This is a weird problem that I hope does not come back.
« Last Edit: May 04, 2014, 02:56:33 am by Greywolf »