BVEStation

Author Topic: Shouldn't be an issue...  (Read 3790 times)

Offline Lashrathorus

  • New Recruit
  • *
  • Posts: 46
  • Gender: Male
  • Chief Executive Officer, NGEX Design Inc.
    • View Profile
Shouldn't be an issue...
« on: July 14, 2013, 03:31:38 am »
I just got myself a new Nvidia GTX 780 for my brand new desktop PC. However, I am noticing a decrease of FPS in exterior views. The comparison is below:

Using R160A:

Interior view - 525 FPS
Exterior view - 120 FPS

Using R46:

Interior view - 125 FPS
Exterior view - only 1 FPS <-- shouldn't be an issue compared to the R160A results

Anyone else with a Nvidia graphics card experiencing this issue?
« Last Edit: July 14, 2013, 04:10:15 am by Lashrathorus »
~ Lashrathius
Official developer of the (R) to Forest Hills.
Teamspeak - ts10.bargainvoice.com:7118

Offline Fan Railer

  • Global Moderator
  • Dispatcher
  • ****
  • Posts: 897
  • Gender: Male
  • Train Developer
    • View Profile
    • Fan Railer's YouTube Channel
Re: Shouldn't be an issue...
« Reply #1 on: July 14, 2013, 10:19:00 am »
I just got myself a new Nvidia GTX 780 for my brand new desktop PC. However, I am noticing a decrease of FPS in exterior views. The comparison is below:

Using R160A:

Interior view - 525 FPS
Exterior view - 120 FPS

Using R46:

Interior view - 125 FPS
Exterior view - only 1 FPS <-- shouldn't be an issue compared to the R160A results

Anyone else with a Nvidia graphics card experiencing this issue?
Have you tried playing with the graphics settings on the card or the OpenBVE program itself?

Offline YankeesPwnMets

  • Head Admin
  • Dispatcher
  • ******
  • Posts: 682
  • Gender: Male
  • Lexington Av Express
    • View Profile
Re: Shouldn't be an issue...
« Reply #2 on: July 14, 2013, 11:46:51 am »
Yeah, all the midrange to higher end graphics cards for some reason have a glitch with openBVE. Since michelle is gone and its been more than a full calendar year since openBVE was updated, this problem may never be fixed.

The most you can really do is download the most up to date drivers.
http://www.geforce.com/drivers/results/63458

If it doesn't work, unfortunately you will be stuck with the same problem as me. Crap performance on a good PC.

Offline Lashrathorus

  • New Recruit
  • *
  • Posts: 46
  • Gender: Male
  • Chief Executive Officer, NGEX Design Inc.
    • View Profile
Re: Shouldn't be an issue...
« Reply #3 on: July 14, 2013, 12:59:36 pm »
Have you tried playing with the graphics settings on the card or the OpenBVE program itself?

Yes - I have high performance settings turned on for games via the Nvidia control panel and have messed with a few settings in openBVE itself.

Yeah, all the midrange to higher end graphics cards for some reason have a glitch with openBVE. Since michelle is gone and its been more than a full calendar year since openBVE was updated, this problem may never be fixed.

The most you can really do is download the most up to date drivers.
http://www.geforce.com/drivers/results/63458

If it doesn't work, unfortunately you will be stuck with the same problem as me. Crap performance on a good PC.

Wow that is actually kinda unfortunate. Although my focus of building this rig is mainly for playing the graphic intensive higher-end games such as GTA IV with HD ENB settings, I still need some good exterior views for the continued extensive preview of the (R). I guess I gotta do some network drives, developing the (R) on my new desktop and beta testing on my laptop.

I'll see if I can mess with openBVE source code since I am a game developer for the mobile app markets. I should be able to pick up the language if I haven't already learned it. Should be C++. Haven't checked or downloaded it yet.
« Last Edit: July 14, 2013, 01:02:04 pm by Lashrathorus »
~ Lashrathius
Official developer of the (R) to Forest Hills.
Teamspeak - ts10.bargainvoice.com:7118

Offline [CT1660]

  • Dispatcher
  • ****
  • Posts: 575
  • Gender: Male
  • openBVE Developer, OMSI Repainter & Engine Modder
    • View Profile
    • Enter The Lair
Re: Shouldn't be an issue...
« Reply #4 on: July 14, 2013, 11:38:48 pm »
Yes - I have high performance settings turned on for games via the Nvidia control panel and have messed with a few settings in openBVE itself.

Wow that is actually kinda unfortunate. Although my focus of building this rig is mainly for playing the graphic intensive higher-end games such as GTA IV with HD ENB settings, I still need some good exterior views for the continued extensive preview of the (R). I guess I gotta do some network drives, developing the (R) on my new desktop and beta testing on my laptop.

I'll see if I can mess with openBVE source code since I am a game developer for the mobile app markets. I should be able to pick up the language if I haven't already learned it. Should be C++. Haven't checked or downloaded it yet.

Actually, it's C#

Offline Lashrathorus

  • New Recruit
  • *
  • Posts: 46
  • Gender: Male
  • Chief Executive Officer, NGEX Design Inc.
    • View Profile
Re: Shouldn't be an issue...
« Reply #5 on: July 15, 2013, 02:14:09 am »
Actually, it's C#

Oh alrighty. I guess when I have some free time I'll see what I can do. I've learned C# before but my C# skills are not as strong as my C++ and Objective-C coding skills. So - might take a while actually. Probs better off waiting for Michelle but I'll see what I can do to help.
~ Lashrathius
Official developer of the (R) to Forest Hills.
Teamspeak - ts10.bargainvoice.com:7118

Offline YankeesPwnMets

  • Head Admin
  • Dispatcher
  • ******
  • Posts: 682
  • Gender: Male
  • Lexington Av Express
    • View Profile
Re: Shouldn't be an issue...
« Reply #6 on: July 15, 2013, 04:46:47 pm »
The problem arises because of an issue with both AMD and nVidia graphics drivers detecting openBVE as a demanding program. If you take a look at GPU usage graphs such as those found in MSI Afterburner, you would find that even with the R46 lagging in openBVE, the graphics core, for some unexplained reason, remains at idle and does not ramp up. I've been trying to look myself for the problem here, but everything I've tried has not worked yet. I don't know if this is a graphics driver issue (in that case it would be up to nVidia and AMD to fix it) or the game's problem itself, but it is certainly very annoying. Perhaps sending a support ticket to nVidia or AMD and having them look at the problems themselves would help. Otherwise, I don't know.

By the way, a topic like this would be better suited for this section of the forums  ;D
http://forums.bvestation.com/index.php?board=24.0

Offline Lashrathorus

  • New Recruit
  • *
  • Posts: 46
  • Gender: Male
  • Chief Executive Officer, NGEX Design Inc.
    • View Profile
Re: Shouldn't be an issue...
« Reply #7 on: July 15, 2013, 09:12:02 pm »
The problem arises because of an issue with both AMD and nVidia graphics drivers detecting openBVE as a demanding program. If you take a look at GPU usage graphs such as those found in MSI Afterburner, you would find that even with the R46 lagging in openBVE, the graphics core, for some unexplained reason, remains at idle and does not ramp up. I've been trying to look myself for the problem here, but everything I've tried has not worked yet. I don't know if this is a graphics driver issue (in that case it would be up to nVidia and AMD to fix it) or the game's problem itself, but it is certainly very annoying. Perhaps sending a support ticket to nVidia or AMD and having them look at the problems themselves would help. Otherwise, I don't know.

By the way, a topic like this would be better suited for this section of the forums  ;D
http://forums.bvestation.com/index.php?board=24.0

Oh now I fully understand the situation. I'll take a look at the MSI Afterburner to check my GPU usage. Don't think I installed it yet cause its a new PC. I'll send nVidia a support ticket and update you on their response.

Thanks for your help ! and sure - I'll put similar topics in that forum section in the future.
~ Lashrathius
Official developer of the (R) to Forest Hills.
Teamspeak - ts10.bargainvoice.com:7118

Offline Lashrathorus

  • New Recruit
  • *
  • Posts: 46
  • Gender: Male
  • Chief Executive Officer, NGEX Design Inc.
    • View Profile
Re: Shouldn't be an issue...
« Reply #8 on: July 20, 2013, 03:01:18 am »
I finally found the solution to 1FPS on the R46 with a GTX 780.

DOWNLOAD OPENBVE v1.4.2. It worked for me. I was running something lower.

Enjoy high FPS.
~ Lashrathius
Official developer of the (R) to Forest Hills.
Teamspeak - ts10.bargainvoice.com:7118