Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Low_V

Pages: [1]
BVE/OpenBVE Support / OpenBve Under Linux/Mono
« on: February 11, 2015, 04:27:27 pm »
Hi, I have successfully been running OpenBve under Fedora 19 and 20 (Linux) running under mono. Everything works flawlessly. When I upgraded to the latest Fedora 21 OpenBve would not run at all. I couldn't even get the program to startup. Apparently the newer versions of mono that are packaged with Fedora 21 no longer support OpenBve. Fortunately I managed to fix the prioblem.  In order to get it up and running I had to downgrade the mono packages to the older ones from fedora 20. As soon as I downgraded to the earliier versions of mono OpenBve started working again.

Wonder if anyone else noticed this problem. In any event I figured I'd post this as a heads up to anyone who might be running OpenBve on Linux via mono. If you are using a current version of mono and OpenBve won;t run you might have to downgrade/install an earlier version of mono in order to get it to work.

Pages: [1]